Saturday, May 07, 2016

Forticlient 64 bits on Ubuntu 16.04

As part of the migration to Xenial Xerus on my Thinkpad X140e, I had to install the Forticlient SSL client no matter what, as I use it a lot for work related stuff.
I had to deal with this a couple of times already...
This time things went somehow smooth:

sudo dpkg -i forticlient-sslvpn_4.4.2313-1_amd64.deb
Selecting previously unselected package forticlient-sslvpn.
(Reading database ... 182887 files and directories currently installed.)
Preparing to unpack forticlient-sslvpn_4.4.2313-1_amd64.deb ...
Unpacking forticlient-sslvpn (4.4.2313-1) ...
dpkg: dependency problems prevent configuration of forticlient-sslvpn:
 forticlient-sslvpn depends on lib32gcc1 (>= 1:4.1.1); however:
  Package lib32gcc1 is not installed.
 forticlient-sslvpn depends on libc6-i386 (>= 2.3.4); however:
  Package libc6-i386 is not installed.

Installed without much fuss, but, stupid me, forgot to issue a dry run first...
Any ways... The Forticlient work A Ok after this (go figure), but the dkpg message seemed a bit ominous and annoying...

First things firt, let's try with the damn dependency error:

sudo apt-get install libc6-i386

dpkg: error processing package forticlient-sslvpn (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:

No luck!

So I gave a shot a refreshing the packages:

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree     
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 forticlient-sslvpn : Depends: lib32gcc1 (>= 1:4.1.1) but it is not installed
                      Depends: libc6-i386 (>= 2.3.4) but it is not installed
E: Unmet dependencies. Try using -f.

And this was right after a fresh install of Xenial...
Issued a:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  guile-2.0-libs libexiv2-14 libgc1c2 libgexiv2-2 libqqwing2v5 libraw15
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  lib32gcc1 libc6-i386
The following NEW packages will be installed:
  lib32gcc1 libc6-i386
0 upgraded, 2 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
Need to get 2,381 kB of archives.
After this operation, 10.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y

And presto, problem solved.

Labels: , , , , , , ,


Post a Comment

<< Home